Firebug 1.8 API Changes

From FirebugWiki

(Difference between revisions)
Jump to: navigation, search
Line 5: Line 5:
* FBL.CCIN, FBL.CCSV and FBL.QI are obsolete, use "firebug/lib/xpcom"
* FBL.CCIN, FBL.CCSV and FBL.QI are obsolete, use "firebug/lib/xpcom"
* firebug-trace-service is obsolete, use "firebug/lib/trace"
* firebug-trace-service is obsolete, use "firebug/lib/trace"
 +
* HTMLLib is not part of Firebug namespace, you need to include "firebug/lib/htmlLib.js

Revision as of 08:10, 9 May 2011

TODO: This is only a rough list of changes, more explanation needed.

  • Firebug source files use Asynchronous Module Definition (AMD)
  • firebug-http-observer (JS module) is obsolete. Use "firebug/http/requestObserver"
  • FBL.CCIN, FBL.CCSV and FBL.QI are obsolete, use "firebug/lib/xpcom"
  • firebug-trace-service is obsolete, use "firebug/lib/trace"
  • HTMLLib is not part of Firebug namespace, you need to include "firebug/lib/htmlLib.js
Personal tools